Support Fran├žais Contact Support

My Questions Aren't Loading


Please note: If you see (HTML5) in the top left of your Device Setup, Practice, or Assessment, please visit this Help page instead.

Device Setup HTML5 Screenshot


Loading a video question, either in your practice or assessment, should take anywhere from a few seconds to a couple of minutes, depending on your internet connection. As a benchmark, they should take about as long to load as the welcome video.

Check Adobe Flash Permissions

If you are using a Chrome browser, click on "Secure", and ensure the Flash settings are set to "Always allow on this site".

Screen_Shot_2018-03-09_at_10.34.19_AM.png

If you are using a Firefox browser, make sure Flash is enabled and the settings are remembered.  If you see a blue dot next to the plug-in icon (looks like a lego piece), make sure to change the correct settings

Screen_Shot_2018-03-26_at_3.29.15_PM.png

Note: This is often the cause if videos suddenly stop loading between questions in your assessment. For example, if your page looks like this 

firefox_enable_screenshot.png

Next Steps

1. Refresh your page.

2. Make sure that both your adblocker and firewalls are disabled as these can sometimes block communication with the platform.

3. Restart your device.

4. If your recording is choppy, it may be a connection issue. Try to establish a stable internet connection.

5. If your issues persist, please contact support@kiratalent.com

Still need help? Contact Us Contact Us