Platform Status Email Support

My Video Questions Aren't Loading

My Video Questions Aren't Loading

Loading a video question, either in your practice or real assessment, should take anywhere from a few seconds to a couple of minutes depending on your internet connection. As a benchmark, they should take about as long to load as the welcome video.

If they do not load, your Flash likely needs to be enabled.


Check your Flash Settings in Chrome

If you are using a Chrome browser, click the lock 🔒button to the left of your address bar, and ensure your Flash is set to Allow.


Check your Flash Settings in Firefox

If you're using a Firefox browser, make sure Flash is "Allowed" and the settings are "Remembered". Click the plug-in icon to the left of your address bar (looks like a lego block) to change tour Adobe Flash settings.

Note: If you see a blue dot next to the plug-in icon, you need to enable Flash to load your video questions.


Not enabling Flash or remembering the decision to allow Flash is often the cause if videos suddenly stop loading between questions in your assessment.


Then, please try the following:

1. Refresh your page and/or go back and complete another Device Setup.

Make sure that both your adblocker and firewalls are disabled as these can sometimes block communication with the platform.

3. Restart your device.

4. If your recording is choppy, it may be a connection issue. Try to establish a stable internet connection.

5. If your issues persist, please contact support@kiratalent.com